本問題における発生条件および対応方法は以下をご確認ください。
■ 製品
・ Windows版検索エンジンを使用する弊社デスクトップ/サーバ製品
Gateway/Groupware製品は対象外です。
■ 発生条件
・ 検索エンジンを8.500へアップデートしている環境
・ 弊社製品のリアルタイム検索を有効にしている環境
・ ターミナルサービスを使用し移動プロファイルを有効にしている環境
・ リモート環境のサーバに保存された移動プロファイルとクライアントが保持するプロファイルの同期を行うアプリケーションの使用
現在までに、Citrix Presentation Server/MetaFrame環境での発生を確認しております。
※ 弊社では、上記条件における現象の発生を確認しておりますが、条件は環境によっても異なるため、この限りではございません。また、本問題の影響度合いは移動プロファイルの数やログインユーザの数にも依存いたします。
■ 切り分け方法
本問題に該当するかを確認するには、弊社製品上にてリアルタイム検索機能を停止、あるいは弊社製品のサービスの再起動にて、現象が発生しなくなるかをご確認ください。
上記によって現象が発生しなくなった場合、本問題に該当する可能性がございます。
■ 原因
弊社製品(検索エンジン)のファイル検索過程における、ファイルクローズ処理の遅延が原因です。
ログイン時にクライアントが保持しているプロファイルとサーバ上の移動プロファイルとを同期する処理において、弊社ドライバによるI/O処理の判定が誤っていました。
これにより、本来追加する必要の無い情報までテーブル(弊社ドライバ専用)に加えたため、アプリケーションへのログインを実施するたびに、当該テーブルの肥大化が発生します。なお、誤って追加された情報は、以降、検索エンジンの動作を停止しない限り削除することができません(通常これらの情報はテーブルのチェック後に削除されます)。
このため、ファイルのクローズ処理が発生した際に、検索エンジンがファイルの検索が必要かどうかを判断するためにテーブルをチェックいたしますが、テーブルが肥大化した事によりチェックに時間がかかり、これに伴いファイルクローズ処理が遅延し、ログイン処理の完了に多くの時間を要する結果となりました。
■ 対処方法
大変お手数ではございますが、本現象に関する修正を施した ウイルス検索エンジン VSAPI 8.550適用のご検討をお願い申し上げます。
ウイルス検索エンジンは下記ページからダウンロード可能です。
適用方法については、同ページ内の各製品毎のインストールガイドをご参照ください。
[検索エンジン・アップデート]
http://www.trendmicro.co.jp/download/engine.asp