印刷する
作成日: 2011-12-16 04:30:21
更新日: 2011-12-16 04:30:21

このページを見た方は以下もチェックしています

ウイルス検索エンジン8.500にアップデート後、コンピュータの再起動時やアプリケーションの起動時にアプリケーションエラーの発生や他のアプリケーションソフトのサービスの起動に失敗する問題

ID: JP-2062153
製品: 全製品 -
OS: Windows NT/2000/2003

ウイルス検索エンジン8.500にアップデート後、コンピュータの再起動時やアプリケーションの起動時にアプリケーションエラーの発生や他のアプリケーションソフトのサービスの起動に失敗する問題が確認されています。

本現象における発生条件および回避方法は以下でご確認ください。

発生環境
・弊社デスクトップ/サーバ製品
・Microsoft Windows 2000

■ 発生条件
・デスクトップヒープの設定をレジストリで変更している。
  デスクトップヒープの設定場所
  レジストリパス:[HKEY_LOCAL_MACHINE¥SYSTEM¥CurrentControlSet¥Control¥Session Manager¥SubSystems]
  レジストリキー:Windows
  値:%SystemRoot%..<中略>.. Windows SharedSection=1024,3072,512..<中略>.. Off MaxRequestThreads=16

  上記の「512」の部分の値を変更している場合が対象です。

・起動時にデスクトップヒープメモリを多量に使用するアプリケーションソフトの導入

※弊社では、上記条件における現象の発生を確認しておりますが、発生条件は各環境によって異なるため、この限りではございません。

■ 原因
検索エンジン 8.500にてメモリの管理技法の追加が行われ、この追加が本現象の発生の可能性を高くしたことが原因です。

■ 対処方法
大変お手数ではございますが、本現象に関する修正を施した ウイルス検索エンジン VSAPI 8.550適用のご検討をお願い申し上げます。
ウイルス検索エンジンは下記ページからダウンロード可能です。
適用方法については、同ページ内の各製品毎のインストールガイドをご参照ください。

[検索エンジン・アップデート]
http://www.trendmicro.co.jp/download/engine.asp


弊社推奨の対処方法はウイルス検索エンジンのアップデートですが、即時アップデートが難しい環境の場合には次項の回避方法もご参照ください。また、下記の回避設定を既に行っていただいている場合でも、そのままVSAPI 8.550を適用いただけます。更に設定変更の必要はございません。

■ 回避方法
ウイルス検索エンジンを即時8.550にアップデートできない場合には、以下の手順をご検討ください。
レジストリに値を追加することで、現象は回避されます。以下の手順でレジストリの設定を行ってください。
なお、この設定は検索エンジン 8.500で追加した新しいメモリ管理技法を無効にするのみとなり、セキュリティ上の機能低下はございません。

1. レジストリエディタなどを使用して、以下のレジストリパスに値を作成します。

 警告
 レジストリはWindowsの構成情報が格納されているデータベースです。
 レジストリの編集内容に問題があると、システムが正常に動作しなくなる場合があります。
 弊社ではレジストリの編集による如何なる問題に対しても保証いたしかねます。
 レジストリの編集はお客様の責任で行っていただくようお願いいたします。
 なお、レジストリの編集前に、必ずバックアップを作成することを推奨いたします。
 バックアップ方法の詳細は、ご使用のWindowsのヘルプをご参照ください。

レジストリパス:[HKEY_LOCAL_MACHINE¥System¥CurrentControlSet¥Services¥VSApiNt¥Parameters]
レジストリキー:DisableSystemView(DWORD値)
値 :1

2. レジストリエディタを終了します。
3. コンピュータを再起動します。

■ 確認方法
設定が追加されたか確認するには、再度レジストリを開き以下のキーと値が設定されていることを確認してください。

このソリューションに関して、ご意見をお聞かせください。
このソリューションは問題解決に役に立ちましたか。
はい いいえ
このソリューションの内容を改善するために、ご提案/ご意見がありましたらお聞かせください。
※こちらに技術的なご質問などをいただきましてもご返答する事ができません。
   何卒ご了承いただきますようお願いいたします。
本ページで問題が解決しない場合はこちらへ